Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 25, 2025 - 08:00 CET
Scheduled
We're upgrading our Platform MongoDB infrastructure to improve stability and performance following recent issues. This upgrade is designed to be seamless, with no expected downtime. All services will remain operational.
Posted Mar 21, 2025 - 11:36 CET
This scheduled maintenance affected: API, Box, and Platform.